Muppet Wiki
Advertisement
Muppet Wiki
38,610
pages
Forums: Index > General Discussion > Bug smashing efforts

Participation in the Muppet Wiki Forums requires a full understanding of the Rules and Etiquette.



Hey all! I am super glad that I get to reach out for this and ask for your input! Some of you may have already read the blog announcement on Community Central about this, but for those who haven't: Fandom announced that it would focus the upcoming 2 weeks on an all-hands quality of life project -- read "a two-week bug squashing effort"!

So my question to you all is: are there perhaps any bugs that have been annoying you since whenever UCP came along? This project is the perfect opportunity for you to get the word out about those things! These don't have to be the big "it's breaking the site" kind of bugs. Just any inconvenience you've encountered ever since UCP rolled out can be reported. This project will run for 2 weeks, so the faster I know about your issue, the more change we have to get it fixed.

When you report something, please send me everything you can about the bug(s), like:

  • what browser are you using (Chrome, Firefox, etc)
  • What editor? VisualEditor? VisualEditor - source mode (also known as the 2010 editor)? Or the source editor (aka the 2010 editor) If you are unsure, you can check which editor you're using via your preferences.
  • Did it happen on mobile or desktop?
  • And most importantly: please include detailed steps to reproduce the bug (even if you think it's glaringly obvious). Providing me with links, screenshots, videos, etc is super useful!

Our best shot to get anything fixed is to be able to clearly explain to an engineer what the problem is, when we encounter it, and how it affects our workflow. So any relevant information you can provide will help them help you!

If you have further questions, don't hesitate to ask! Lady Lostris / 9?cb=20190922130322 SOAP 14:57, 13 March 2021 (UTC)


Episode 0001 SHOW PREVIEW.

Thanks for reaching out, Lostris. Since we were moved to UCP five months ago, I've been regularly reporting bugs to Staff. Some have been fixed, some are still pending. I've been tracking them at User:Scarecroe/UCP, but I haven't updated that in a while, so I haven't struck out stuff that's been fixed or addressed yet. A lot of them I've been able to fix with CSS, but there are still several inconveniences.
One of them I'll bring attention to is the preview for Sesame episode pages which is messing up the tables. It's no doubt happening because of the templates we're using to hide some cells, but this didn't happen before UCP. I haven't reported it because it's cosmetic, but I haven't gotten around to finding the time to fix it myself yet either. I think this is less a problem to report to the technical staff, and more of one that's just good at templates can probably help out with.
Anyway, I encourage others to point out other bugs they've found. β€”Scott latest?cb=20200820192427 (talk) 15:22, 13 March 2021 (UTC)
Are we submitting these through the usual Support tickets or are we posting them here/somewhere else? - Oscarfan (talk) 19:55, 13 March 2021 (UTC)
Special:WantedPages right now is full of "Thread:" and other broken stuff from the old forums. At least four are linked to from over 100 hundred pages, so if there's a way to repair/remove that without us manually unlinking, it sure would help. There's also an issue, which Scott mentioned on his UCP list, where help pages that link to Community Central are instead registering as if they're redlinked/wanted pages. -- Andrew Emoji-drool.gifAdminsig.png 23:21, 13 March 2021 (UTC)
Here are a couple I've previously submitted through Zendesk, but they haven't been addressed yet:
#1026914
#1009943 (this worked before UCP)
Thanks. β€”Scott latest?cb=20200820192427 (talk) 12:31, 14 March 2021 (UTC)
Here's another one, not yet reported. While editing in source mode, automatic link suggest only works some of the time. In cases when it's working upon first editing the page, it often stops working if you click SHOW PREVIEW. This seems to be related to javascript sometimes not working until the page is refreshed (noticeable with some of the w:c:dev scripts we're using). β€”Scott latest?cb=20200820192427 (talk) 16:59, 14 March 2021 (UTC)

You can all just report it here, cause then I know directly which issues you're most annoyed by, which makes it easier for me to keep track of things and give you updates.

Re table preview issues: there are lots of preview issues in general on UCP. So while that's likely indeed caused by the template, the preview should still be a literal preview of how the page will look once published. Which page is that you took the screenshot of? I would like to see the table first before making a ticket out of it.

Re help pages showing up on Special:WantedPages: this was ticketed before, and I added your report to it. The red links for threads is also known, so I'll look into that as well to add your report to the ticket/create a new ticket about it.

I don't have access to the zendesk tickets, so I'm finding out which ticket's you're referring to and will get back to you.

For the things mentioned in the sandbox, some quick notes:

  • gallery perrow is broken: use "columns=X" instead
  • Special:Editcount: this needs to be enabled now via WikiConfig, which I can do for you

For most of that sandox, I'm going to need a rundown for a lot of them to know in more detail what you're referring to and/or what behavior you're missing/expecting. Lady Lostris / 9?cb=20190922130322 SOAP 10:28, 15 March 2021 (UTC)

Which page is that you took the screenshot of?
The one linked in the image caption. But any Sesame episode page will do.
Is "columns=X" as a replacement for "perrow=X" a long-term situation? Standard MediaWiki language format is perrow, so I don't want to have to change them all again if Fandom decides they want to swap it back. Thanks! β€”Scott latest?cb=20200820192427 (talk) 11:27, 15 March 2021 (UTC)
Ah lol, thanks. That was too obvious and logical for me to see.
Mmm, digging a bit deeper into it, I would leave it for now. Lady Lostris / 9?cb=20190922130322 SOAP 12:56, 15 March 2021 (UTC)
Re the unused files issue: is that about images in a gallery/slideshow not showing up as being used? Lady Lostris / 9?cb=20190922130322 SOAP 13:02, 15 March 2021 (UTC)

Category:Muppet Sing Alongs.

Adding this one to the pile. We ultimately lost access to our old discussion posts due to UCP migration, and yet they appear in our edit history and, more pointedly, are able to be categorized. Because it's broken, we are unable to manually edit the message to remove the linked category. β€” Jon latest?cb=20200820192427 (talk) 14:48, 15 March 2021 (UTC)
There was one UCP bug where the previous file displays the same date as the new one making the older revisions incorrect which got fixed before this was started.Muzzarino
That was indeed a bug, but as you noted, it was fixed.
Re broken links: that ties together, so I'm seeing what can be done about that. Lady Lostris / 9?cb=20190922130322 SOAP 15:29, 15 March 2021 (UTC)

There have been a few issues I've been experiencing recently. All these problems are in Chrome using the Source Editor:

  • On certain pages, the editing alignment and the actual text are a line apart; I need to be in the space above the text to actually affect that particular line. Photo examples from Episode 5114. MWIssue-Code01.png MWIssue-Code02.png
  • Linking is still an issue, with the hyperlink selections extending beyond the editing window. MWIssue-Links.png
  • Mass upload has become the same problem as well. I can't scroll all the way to the bottom of it to actually hit "Upload"; I have to zoom by browser window far out in order to see it. MWIssue-MassUp01.png MWIssue-MassUp02.png
  • Galleries essentially don't work in Preview mode; they just appear as a list of the pictures with no orientation.
  • If I copy a file name from the file preview window, when pasting it into an actual page, it MWIssue-FileCopy01.png MWIssue-FileCopy02.png

That should be about it for me. - Oscarfan (talk) 18:41, 15 March 2021 (UTC)

There is a tool for bulk photo uploading on the developer wiki if you need it while the bug's in place.Muzzarino
@Oscarfan:
  1. I can't reproduce the first thing you reported. How/when exactly does that appear?
  2. This is a known issue that was ticketed before. I've added your report to it.
  3. Interesting that it happened on Chrome. Issues with that have been reported for Safari, but I'll add it to the ticket as well!
  4. Can you link me to a gallery page where you're seeing the issue? When you say that you're using the Source Editor, I take that as you're using the 2010 editor. What preview option are you using? Show preview on first edit, Show preview before edit box, or Show previews without reloading the page? (you can check in your preferences, editing tab)
  5. From your report, I went to the dog page, clicked a random file, selected and copied the name from the file tile, and just pasted that on another page. That just renders as "Ace_Yu.jpg" for me. Can you elaborate on the steps to reproduce your error? Lady Lostris / 9?cb=20190922130322 SOAP 11:03, 17 March 2021 (UTC)

Here's another victim of Fandom's assassination of our wiki communication tools: Special:WhatLinksHere/File:Sesame20pressphoto.jpg shows up in Special:WantedFiles, but since Forums were nuked with no backup and no way to reference a decade's worth of collaboration, there's seemingly nothing that can be done about cleaning this up. Which is a much smaller problem compared to all of our lost work over the years thanks to the implementation of a non-wiki product which replaced a perfectly fine Forum that worked within the wiki. β€”Scott latest?cb=20200820192427 (talk) 15:03, 17 March 2021 (UTC)

@L.L.
Point 1: I don't know when it happens/doesn't happen. It seems to be on certain pages. Looking at that particular page I linked to right now, I'm seeing the red underline for unknown spellings for "Hailee Steinfeld," but the line is above the name, not under it. If I zoom my window out, those lines shift position in the editor and where I was clicking/typing before affects lines far below where I was.
Point 4: This issue seems to be resolved since I wrote it. It wasn't working on pages like Oscar's family before.
Point 5: So, I'll go to the Image Activity page, click on the thumbnail of one of the images, and it brings up the preview window with the file name at the top. If I try to copy the file name from the text on that preview window, when I paste it into another page, it causes that large spacing issue.
Hope these further clarify what I was tying to say. - Shane (talk) 15:08, 17 March 2021 (UTC)
@Oscar: I'm sorry, I still can't reproduce the image copying thing, nor the red line :-/
The linking issue and multiple upload have been fixed by now.
If the gallery issue returns, be sure to let me know. There are some related tickets. I think I've found the one you're referring to, so I added your report to it just to be sure. Lady Lostris / 9?cb=20190922130322 SOAP 19:55, 21 March 2021 (UTC)
I'm not seeing any difference in the linking/mass upload features (I did Purge; should I clear my browse cache or something?). - Oscarfan (talk) 00:06, 22 March 2021 (UTC)
Sorry, should've elaborated immediately: the tickets are fixed but still need to roll out, which is scheduled to happen on Tuesday. So if you still have issues with it on Wednesday (I'm taking timezones into account), don't hesitate to flag it again! Lady Lostris / 9?cb=20190922130322 SOAP 00:15, 22 March 2021 (UTC)

Search has been broken since we moved to UCP five months ago. You should be able to type "kermit the frog" into the search bar and land right on Kermit the Frog, but instead you get a list of search results. Here's a video showing how it works on Fandom vs how it should work (and how it used to work here) on Wikipedia. This was reported to Staff over three months ago in Zendesk ticket #1009943, but it has not yet been addressed.

Also, if you go to Special:ListGroupRights, scroll down to content-moderator, and click (list of members), the proper members with those rights aren't being filtered. This used to work before UCP. β€”Scott latest?cb=20200820192427 (talk) 12:22, 22 March 2021 (UTC)

I'll ask around for the faith of the Zendesk ticket. I created a ticket for the list of members link not being properly formatted. As you may have figured out yourself already, the issue there is that the link leads to Special:ListUsers?group=WHATEVER, which doesn't work. As a workaround, you can change that "?group=" by a /, so to create Special:ListUsers/WHATEVER, and it will work. Lady Lostris / 9?cb=20190922130322 SOAP 15:27, 22 March 2021 (UTC)
That's the problem, https://muppet.fandom.com/wiki/Special:ListUsers?group=content-moderator doesn't work. How do I see people in the group content-moderator? β€”Scott latest?cb=20200820192427 (talk) 15:33, 22 March 2021 (UTC)
That what I just said: the links indeed don't work, but if you manually change the url to https://muppet.fandom.com/wiki/Special:ListUsers/content-moderator (so replace "?group=" by a /), it does work. This still very much is a bug that needs to be fixed, hence the ticket, but that's how you can work with it in the meantime.
As for the go-search case insensitive searching: it is partially fixed. Your initial report lead to the issue being fixed for instances where there is only one space in the search term. Search "jim henson" will now lead to "Jim Henson" directly, but when there's more than one space, such as with "Kermit the frog", you still end up on Special:Search. I filed a new ticket for that, linking back to the old one, so hopefully a similar fixed can be created soon. Lady Lostris / 9?cb=20190922130322 SOAP 16:15, 22 March 2021 (UTC)
Ah, I see. I changed the url wrong. Thanks!
Thanks also for the case sensitive search ticket. Will a fix for three words also apply to four (the muppets take manhattan, for example) and so on? β€”Scott latest?cb=20200820192427 (talk) 16:25, 22 March 2021 (UTC)

Hopefully, but just to be sure, I'll add that page to the examples given on the ticket. Lady Lostris / 9?cb=20190922130322 SOAP 16:30, 22 March 2021 (UTC)

Whenever I hover the cursor over a cited source or a popup picture in Chromium, which is my preferred method of going through the Wiki, the source and picture don't show up. For instance, when I hover over Elmo's World Monster Edition in the Elmo's World article, nothing happens. β€”Anthony (|talk) 07:42, 23 March 2021 (UTC)

That link is not a reference but rather the Template:Popup that's causing you trouble. I still see the image popping up (Chrome), though it pups up in the middle of the sentence the template is on rather than above the template link itself. Lady Lostris / 9?cb=20190922130322 SOAP 09:19, 23 March 2021 (UTC)
Template:popup works fine for me in Firefox and Chrome. Anthony, what browser are you using? β€”Scott latest?cb=20200820192427 (talk) 11:14, 23 March 2021 (UTC)
I don't know if this UCP bug, but the Search doesn't start to show any results unless there's four or more characters typed out. So if I type in "Bob," nothing comes up. - Oscarfan (talk) 16:01, 23 March 2021 (UTC)
I've previously been told that that's a feature, not a bug. β€”Scott latest?cb=20200820192427 (talk) 16:04, 23 March 2021 (UTC)
The browser I use is called Chromium. β€”Anthony (|talk) 09:16, 24 March 2021 (UTC)

Navigating to Special:ListAdmins then clicking a column to sort, removes the rights filtered in that view. β€”Scott latest?cb=20200820192427 (talk) 16:06, 24 March 2021 (UTC)

There's a ticket that's in the testing phase about readding certain right boxes (like administrator, bureaucrat, etc). We assume that once that ticket goes live, this issue will also be fixed, cause when you sort users by ticking one of the boxed provided to you on Special:ListUsers, you do get the desired result. Either way though, thanks for flagging this again, which allows us to verify that behavior before the ticket gets closed! Lady Lostris / 9?cb=20190922130322 SOAP 17:05, 24 March 2021 (UTC)

Text from ticket 1026914:

β€œIs there a way to change which image is used when another website generates a thumbnail for a link on Fandom.com?

I've attached a screenshot of the thumbnail Twitter generated for a link to Jerry Juhl.

As you can see, the image is not a great representation of the topic. Instead of grabbing the first picture in a gallery, it should be looking to the top most image. In this example, there are lots of opportunities for software to get a better image rather than one down on the bottom of the page.

This is just one example, but it happens often, and not just on Twitter. Other social media platforms have shown the same, as well as messaging apps and rich text message boards.”

George left a response that it was being looked into, but I haven't heard any follow-up. β€”Scott latest?cb=20200820192427 (talk) 17:21, 24 March 2021 (UTC)

I can confirm that the special:ListUsers/sysop sorting will be fixed once the userbox gets added to the sorting options.
Kirkburn added your report to the existing ticket about it, and I just upped the severity of the issue due to your request. Lady Lostris / 9?cb=20190922130322 SOAP 10:37, 25 March 2021 (UTC)
There's also still the issue of javascript not working when a page initially loads. This applies to anything that's been imported from dev, but also our own custom (and approved) changes like WhatLinksHere generating a list in alphabetical order. Example at Special:WhatLinksHere/Kermit_the_Hermit_(human) (this is an intermittent problem, so the bug may not reproduce right away). Browser: Firefox.
Generally speaking, browser compatibility has been very poor since the UCP move. If you're not using Chrome (desktop and mobile included), you're looking at a fairly broken wiki. β€”Scott latest?cb=20200820192427 (talk) 16:32, 26 March 2021 (UTC)
Is anyone else experiencing this? On Category:Sesame Street Episode Guide, all but one result on each "page" are in one single line. - Shane latest?cb=20200820192427 (talk) 20:43, 4 April 2021 (UTC)
There's now 4589 pages in the Sesame episode category, but when you use the PAGESINCATEGORY format it says 4,585. If there's any way that can be fixed, I'd be very happy. β€”Anthony (|talk) 03:38, 5 April 2021 (UTC)